Category Archives: content filter

Something smells funny at urlblacklist.com

Competition is great, it drives innovation and gives companies the incentive to improve and the drive needed to continue to improve services and products. And in the spirit of competition sometimes a little dirt gets slung. But it isn’t only serving our personal interests to outline the failures of one of our competitors today. In this case, I believe that it is in fact doing the public a service. And by this I mean spreading awareness, to warn unsuspecting customers of what they are spending their money on, and of course, to convince you. with a little sound reasoning, to purchase our services instead of the competition.

There aren’t many suppliers of domain blacklist data for web filtering platforms and applications, this is one of the primary motivating reasons why we created Squidblacklist.org in 2012. We knew it could be done better. There are however a small handful of other providers remaining. One of these websites is urlblacklist.com, and it is them whom we have chosen to single out for scrutiny in this blog post.

In summary, Urlblacklist.com is a horrible service provider. One whos website was recently down for over 3 months in the 2016 calendar year. As a provider of services to paying clients, this is simply a disgrace. We have been monitoring urlblacklist.com, watched multiple outages, and we know that their domain name changed hands recently, something they did not announce on their website, so we will do it for them, here.

The website urlblacklist.com was down for nearly an entire month in October 2016. Then, a second outage occured that lasted nearly 2 months, beginning on or around Nov 10, lasting through until Dec 30, 2016. Further scrutiny reveals that in Nov of 2016, the owner of urlblacklist.com irresponsibly allowed his domain name to expire, which resulted in another 2 month long outage, in which another company took the opportunity to purchase the domain name, which is now registered under an entity named “Dr Guardian” who one can only assume has taken ownership and reopened the website, and is actively processing payments by unsuspecting customers.

They also do not make any mention of ownership changing hands anywhere on their website, a courtesy any respectable business would extend to its existing clients and the general public. Instead of even acknowledging the domain name ownership change. they choose to deceptively place blame for the outage on a billing issue with their registrar.

And I doubt if anybody knows who is really even operating the website. The owner has never responded to emails, doesn’t seem too care if his website goes down until months later, and I suggest that you should seriously consider switching to Squidblacklist.org if you are a current urlblacklist.com subscriber.

A brief visit to urlblacklist.com shows that the owner would like you to believe the second extended outage of 2016 was brief, a deception which is evident in a recent “news” message claiming that “over Christmas vacation” there was an outage, I guess Christmas vacation begins around Nov 10 and ends December 30th.

One can safely assume by looking at the ancient and truly aweful web design of urlblacklist.com and then research its track record of unreliability, and make some general conclusions about its owner and or operators which are to say, generally not favorable at all. And this lack of integrity can also be found in the quality of their blacklists, or lack thereof, which is of course, what really matters.

Urlblacklist.com is an aging website. I would encourage you to use their lists, and monitor the daily changes, you will know first hand that nearly 60% of the domains in their blacklists do not even resolve, a good indicator that there is very poor technology behind the update processes going on behind the scenes. It becomes clear rather quickly that they are pushing old, recycled domain data by systematically removing a set number of domains and re-adding them back using some crude scripts or something, rotating this data in and out in a way which gives the customer the illusion that updates are taking place.

With manual additions and removals being performed occasionally presumably by human hands. Beyond this however, there is obviously zero innovation taking place at urlblacklist.com. Which is evidently ran by an incompetent individual who is doing the world a disservice by continuing to accept payments for what is, in our opinion, hardly passable even as a purely free service.

Shalla and any other websites referring people to this website are also guilty of doing the general public a disservice by linking to urlblacklist.com because clearly anybody who has actually observed or used the lists from these people should come to the same conclusions that we have, and that is urlblacklist.com is an unreliable provider of services that needs to go away.

Also make note that shady clones of urlblacklist.com are also in existence, these domains are registered by totally different owners.
http://schwela.com is one of them.


If you like what we are doing here and want to support our efforts, please consider subscribing to download all of our blacklists.

Flat rate subscription. For full access to all of our works, select a membership option & subscribe today.



Select Payment Option




OPNSense developers add support for Authentication – Enabling Blacklists from Squidblacklist.org

OPNsense Firewall Distribution
OPNsense Firewall Distribution

After a brief exchange via email, one of the developers of OPNsense has contributed a modification that will allow for an option to authenticate using credentials for downloading blacklists, something which is essential for Squidblacklist.org members to use and update blacklists with OPNsense. This change will be available in the upcoming 16.7.7 release of OPNsense.

In the coming days and weeks further testing and collaboration should follow, to ensure full functionality, such as automated updates with scheduling options and features. And standard testing for any issues that may arise, but we are very excited to see progress being made. And would like to express our gratitude to the developers who are donating their time and effort to make the world a better place for the end user.

I will post a full review once final testing has concluded and the resultant product is solid, we will also update our materials to reflect the latest changes when we reach this point and confirmation compatibility and stability are achieved.


If you like what we are doing here and want to support our efforts, please consider subscribing to download all of our blacklists.

Flat rate subscription. For full access to all of our works, select a membership option & subscribe today.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


New Blacklist: A List of Terrorist & Extremist Domains.

We have been working to compile the initial release of a new blacklist, which we have now released in the members area of Squidblacklist.org. Available for immediate download, our new and unique “Terrorism and Extremism” Domain Blacklist. Available now for all current and new subscribers. As is always, we have formatted this blacklist for use with multiple platforms.

DNS Zone format, RouterOS DNS and Web Proxy *RSC import script, Squid Proxy Native ACL format, as well as plain text Dansguardian/SquidGuard Compatible format for use with all other web filtering platforms and applications.

Subscribe today and find out why so many have switched. Shouldnt you be using a higher class blacklist?

We are committed to continually evolve the technology we are using on the backend to produce ever increasingly better publications, We are proud to consistently bring ever more refined and simply the highest quality blacklists available.


Subscribe Now For Zone Access.

Flat rate subscription. For full access to all of our works, select a membership option & subscribe today.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Updates and Changes to Mikrotik RouterOS Blacklists

There have been some changes in the latest version of Mikrotik RouterOS, which meant we really had no choice but to make some minor changes, otherwise the old format simply would fail to work when you tried to load them into a current version of Mikrotik RouterOS ( version v6.37 or newer ).

It seems Mikrotik decided, for whatever reason, to change the way static dns entries are handled.

RouterOS DNS Static Entry Change - Side by Side Comparison
RouterOS DNS Static Entry Change – Side by Side Comparison

As you can see in the image above , the changes were significant enough to force us to make the changes, if you are havin any issues loading our blacklists then you should update to the latest version of RouterOS as soon as possible.

We also decided that it would be best to add a single line to the headers included in each blacklist, to remove old entries befoe loading the new ones. Of course any knowledgeable admin would know to do this, but we felt is was something that should already be included in the blacklists for your convenience.

NEW FORMAT:

# TiK-DNS-Ads: Blacklist compiled by SquidBlacklist.org 10-01-2016. -MADE IN USA-
:log info "tik dns ads blacklist script import started"
:local redirectIP "127.0.0.1"
/ip dns static remove [find comment="sbl ads"]
/ip dns static
add regexp="^(.*\\.)\?004\\.frnl\\.de\$" address="$redirectIP" comment="sbl ads"
add regexp="^(.*\\.)\?01s\\.net\$" address="$redirectIP" comment="sbl ads"
add regexp="^(.*\\.)\?01viral\\.com\$" address="$redirectIP" comment="sbl ads"
add regexp="^(.*\\.)\?0427d7\\.se\$" address="$redirectIP" comment="sbl ads"
add regexp="^(.*\\.)\?0702\\.de\$" address="$redirectIP" comment="sbl ads"
add regexp="^(.*\\.)\?0ca\\.net\$" address="$redirectIP" comment="sbl ads"

I hope this will help to clarify for those of you who are scratching your heads about the sudden changes.

Thank you for your support.

Signed,

Benjamin E. Nichols
http://www.squidblacklist.org


Blacklisting has Evolved. Subscribe Now!

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Blacklist Processing – Automated Domain Addition & Removal – A.D.A.R. System – Delay Pool Recheck Function

A little peek at some of whats going on behind the scenes.

One of the things that we do when we process the data that we publish, is to add domains, but also to remove unwanted, or delisted domains that match a certain criteria. But its never a good idea to simply delete the data, instead, we place these removed domains into the delay pools, domains that are flagged as no longer resolving, or being redirected to place holders, which is common with domains that are parked or suspended. Once this data is added to a delay pool, the data is then rechecked again and again, if the domains ever come back online, they get added back to the blacklists again before being white washed through filters again later during our daily update processes.

At Squidblacklist.org, we are working to bring you a higher class of blacklist through logic and innovation.


If you like what we are doing here and want to support our efforts, please consider subscribing to download all of our blacklists.

Flat rate subscription. For full access to all of our works, select a membership option & subscribe today.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Competitor website urlblacklist.com down for over a week.

urlblacklist.com is down
urlblacklist.com not loading

Well we hate to kick sand in the face of a competitor when they are down, ( actually no, we love it ) but seriously, we have been receiving reports that they have been down for over a week now, and lets be honest, downtime is a sin, and an unforgivable one. Being a provider of critical web filtering services requires a high degree of commitment and entails a responsibility to those whom depend on you to continuously produce quality updates in a timely basis with nearly 100 percent uptime and adequate bandwidth to ensure that you provide your clients, subscribers, and members systems and applications with the level of reliability that is not only expected, but required in 2016 for such a service provider.

The good news is that we do know how to keep our website up and running, and now have available all of our blacklists compressed into a single archive, with identical directory structure for users of urlblacklist to switch to seemlessly. Squidblacklist.org is bringing to market an evolved blacklist generation method, enhanced filters and automated domain removal and addition tools, enforced whitewashing and more, multiple updates daily with bleeding edge malicious updates from multiple sources and partners, we are here to raise the standard and serve you with a higher class of blacklist, and of course, we know how to keep a webserver running.

Sign up today and find out why Fortune 500 Companies, US DoD, Governments, Universities, and Municipalities worldwide are all using blacklists from Squidblacklist.org to enhance a wide range of web filtering applications and platforms.


Blacklisting has Evolved. Subscribe Now!

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


New Option Available for Urlblacklist/Shallalist Compatible Platforms!


We heard you loud and clear, you wanted our enhanced blacklists in a similar archive/file structure as shallalist & urlblacklist for your web filtering platform, so we finally did it!

pfSense Blacklist Update
pfSense Blacklist Update

Available now to all squidblacklist.org members is the new “Universal Archive Structure Format” for any platform coded for shallalist or urlblacklist file structured archives!
Untitled

This new option is available for immediate download to all Squidblacklist.org visitors in the members area of the website, a subscription is required.

Untitled2

Enhance your web filtering strategy with enhanced blacklists and subscribe today.


Blacklisting has Evolved. Subscribe Now!

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Music website/domain blacklist for content filtering published.

We have had a video, and an image blacklist for a while now, so it only seemed right to include a music blacklist. This became clear as it was requested by one of our current members who is responsible for content filtering at an educational facility.

The new Music domain blacklist for web filtering purposes has been added to our existing line up and is available in the ‘all’ archive as well as standalone download, just as you would expect any other blacklist that we offer, this blacklist is also available in multiple formats for broad compatibility with most content filters and url filtering platforms and applications.

Enhance your web filtering strategy with enhanced blacklists and subscribe today.


Blacklisting has Evolved. Subscribe Now!

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Case Study – Web Filtering & Blacklist Quality Put To The Test.

DSC00728
Web filtering is an important consideration for any enterprise – it is one of the best-known and most efficient front line defenses against hacker attacks and malicious software. One of Squidblacklist.org customers was using a solution from another vendor which had reached end of life and needed to be replaced.

The system had not been performing to the customer’s satisfaction – it had proven difficult to manage, was not cost-effective, and its limited reporting capacity required an additional application to fill in the gaps in its functionality.

The client carried out an independent evaluation and selected two blacklist providers for deployment on separate Internet links to test the varying degrees of effective filtering. Filtering policies were created based on group membership rather than individual user rules as in the previous installation, and were integrated into Active Directory.This allowed existing support staff to grant Internet access by moving users into relevant Active Directory groups rather than modifying the proxy server configuration.

Improved Web Filtering Performance

Not only did the new Blacklists from Squidblacklist.org enhance the effective application of these appliances and the performance of web filtering for the customer, they also identified a number of websites which had been previously been mistakenly blocked or likewise, websites that should have been block, not blocked at all. The client was thus able to advise the relevant organizations – which included their customers and partner organizations – that their web filtering solutions had been compromised by poor quality blacklists from websites like shalla “secure services” and urlblacklist. These issues were then easily resolved by converting to blacklists by Squidblacklist.org.

The enhanced blacklists also introduced Weaknetlabs Technology which combines the best of conventional tools with new intelligent identification algorithms. ADR automatically tracks and adds or removes different domains. More effectively producing higher class of blacklists, than first generation blacklists from other providers. It also removes the inherent weaknesses in using human-only classification to give you the most up-to-date URL blocking and control.

The customer has since found that this new setup meets their requirements to an infinitely higher degree than their previous setup.


Blacklisting has Evolved. Subscribe Now!

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now available.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


Study – Internet Filters Block Many Useful Sites

Access_Denied_day_02

Teenagers who look to the Internet for health information as part of their “wired generation” birthright are blocked from many useful sites by antipornography filters that federal law requires in school and library computers, a new study has found.

The filtering programs tend to block references to sex and sex-related terms, like “safe sex,” “condoms,” “abortion,” “jock itch,” “gay” and “lesbian.” Although the software can be adjusted to allow access to most health-related Web sites, many schools and libraries ratchet up the software’s barriers to highest settings, the report said.

“A little bit of filtering is O.K., but more isn’t necessarily better,” said Vicky Rideout, vice president of the Henry J. Kaiser Family Foundation, which produced the report, to be published today in The Journal of the American Medical Association. “If they are set too high, they can be a serious obstacle to health information.”

The researchers found that filters set at the least restrictive level blocked an average of 1.4 percent of health sites; at the most restrictive level, filters blocked nearly 25 percent of health sites. The amount of pornography blocked, however, was fairly consistent: 87 percent at the least restrictive level, 91 percent at the most restrictive.

The programs blocked a much higher percentage of health sites devoted to safe-sex topics: 9 percent at the least restrictive level and 50 percent at the most restrictive. The blocked pages at high levels included The Journal of the American Medical Association’s site for women’s health and a page with online information from the Food and Drug Administration about clinical trials.

To the researchers, the results mean that a school or library that uses a less restrictive setting for Internet filters can lose very little of the protective effect of the filters, while minimizing the tendency of filters to block harmless and even valuable sites.

The report is the first major study of the effectiveness of filters to appear in a peer-reviewed scientific journal, and the first to look at the effectiveness of filters at various settings. Most previous studies have been produced by organizations with a strong point of view either favoring or opposing filters. The Kaiser Foundation is a nonprofit health research group. David Burt, an antipornography advocate who is a spokesman for the filtering company N2H2 , said he was pleased with the report, which he called “very thoughtful and well designed — they recognized it matters a lot how you configure a filter and set it up.”

But opponents of filtering requirements said the study showed the technology’s clumsiness.

“Filters are just fine for parents to use at home,” said Judith F. Krug, director of the Office for Intellectual Freedom at the American Library Association. “They are not appropriate for institutions that might be the only place where kids can get this information.”

“The importance of the First Amendment,” Ms. Krug said, “is that it provides us with the ability to govern ourselves, because it guarantees that you have the right to access information. The filters undercut that ability.”

Nancy Willard, an Oregon educator who has written student guides that emphasize personal responsibility in Internet surfing, called filtering a kind of censorship that, if performed by the schools directly, would be unconstitutional.

“These filtering companies are protecting all information about what they are blocking as confidential trade secrets,” Ms. Willard said. “This is nothing more than stealth censorship.”

The study was conducted for the foundation by University of Michigan researchers, who tested six leading Internet filtering programs. The researchers searched for information on 24 health topics, including breast cancer and birth control, and also for pornographic terms. They performed the tests at each of three settings. At the least restrictive setting, only pornography is supposed to be blocked; an intermediate setting also bars sites with nudity and other controversial material like illicit drugs. The most restrictive setting possible for each product may block sites in dozens of other categories.

The researchers then called 20 school districts and library systems around the United States to ask how they set their filters. Of the school systems, which teach a half million students over all, only one set its filters at the least restrictive level.

The issue of library filtering is making its way through the federal courts. Last month the Supreme Court agreed to hear a Bush administration defense of the Children’s Internet Protection Act, the federal law requiring schools and libraries to use filters on computers used by children or to lose technology money. A special panel of the United States Court of Appeals for the Third Circuit, in Philadelphia, struck down part of the law that applied to libraries as unconstitutional. Chief Judge Edward R. Becker wrote that filters were a “blunt instrument” for protecting children.

eenagers who look to the Internet for health information as part of their “wired generation” birthright are blocked from many useful sites by antipornography filters that federal law requires in school and library computers, a new study has found.

The filtering programs tend to block references to sex and sex-related terms, like “safe sex,” “condoms,” “abortion,” “jock itch,” “gay” and “lesbian.” Although the software can be adjusted to allow access to most health-related Web sites, many schools and libraries ratchet up the software’s barriers to highest settings, the report said.

“A little bit of filtering is O.K., but more isn’t necessarily better,” said Vicky Rideout, vice president of the Henry J. Kaiser Family Foundation, which produced the report, to be published today in The Journal of the American Medical Association. “If they are set too high, they can be a serious obstacle to health information.”

The researchers found that filters set at the least restrictive level blocked an average of 1.4 percent of health sites; at the most restrictive level, filters blocked nearly 25 percent of health sites. The amount of pornography blocked, however, was fairly consistent: 87 percent at the least restrictive level, 91 percent at the most restrictive.

The programs blocked a much higher percentage of health sites devoted to safe-sex topics: 9 percent at the least restrictive level and 50 percent at the most restrictive. The blocked pages at high levels included The Journal of the American Medical Association’s site for women’s health and a page with online information from the Food and Drug Administration about clinical trials.

To the researchers, the results mean that a school or library that uses a less restrictive setting for Internet filters can lose very little of the protective effect of the filters, while minimizing the tendency of filters to block harmless and even valuable sites.

The report is the first major study of the effectiveness of filters to appear in a peer-reviewed scientific journal, and the first to look at the effectiveness of filters at various settings. Most previous studies have been produced by organizations with a strong point of view either favoring or opposing filters. The Kaiser Foundation is a nonprofit health research group. David Burt, an antipornography advocate who is a spokesman for the filtering company N2H2 , said he was pleased with the report, which he called “very thoughtful and well designed — they recognized it matters a lot how you configure a filter and set it up.”

But opponents of filtering requirements said the study showed the technology’s clumsiness.

“Filters are just fine for parents to use at home,” said Judith F. Krug, director of the Office for Intellectual Freedom at the American Library Association. “They are not appropriate for institutions that might be the only place where kids can get this information.”

“The importance of the First Amendment,” Ms. Krug said, “is that it provides us with the ability to govern ourselves, because it guarantees that you have the right to access information. The filters undercut that ability.”

Nancy Willard, an Oregon educator who has written student guides that emphasize personal responsibility in Internet surfing, called filtering a kind of censorship that, if performed by the schools directly, would be unconstitutional.

“These filtering companies are protecting all information about what they are blocking as confidential trade secrets,” Ms. Willard said. “This is nothing more than stealth censorship.”

The study was conducted for the foundation by University of Michigan researchers, who tested six leading Internet filtering programs. The researchers searched for information on 24 health topics, including breast cancer and birth control, and also for pornographic terms. They performed the tests at each of three settings. At the least restrictive setting, only pornography is supposed to be blocked; an intermediate setting also bars sites with nudity and other controversial material like illicit drugs. The most restrictive setting possible for each product may block sites in dozens of other categories.

The researchers then called 20 school districts and library systems around the United States to ask how they set their filters. Of the school systems, which teach a half million students over all, only one set its filters at the least restrictive level.

The issue of library filtering is making its way through the federal courts. Last month the Supreme Court agreed to hear a Bush administration defense of the Children’s Internet Protection Act, the federal law requiring schools and libraries to use filters on computers used by children or to lose technology money. A special panel of the United States Court of Appeals for the Third Circuit, in Philadelphia, struck down part of the law that applied to libraries as unconstitutional. Chief Judge Edward R. Becker wrote that filters were a “blunt instrument” for protecting children.


Subscribe Today – Paypal or Credit Card Accepted.

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 5 Year Membership Option now vvailable.
  • For lifetime membership options click here.clipart
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.