Mikrotik RouterOS Malicious IP Blacklist – Firewall Import Script – Gratis

Happy New Year! @Mikrotik @RouterOS fans!

logo_new800

We have published a malicious ip blacklist for free! Combined dshield and spamhaus malicious blacklists formatted for Mikrotik RouterOS .rsc import script to firewall address list, updated daily and formatted by our servers for easy import and download into your Mikrotik Router.

It can be downloaded directly here. Or follow the instructions below to setup firewall rules and schedule automatic daily updates on any Mikrotik Router.


To automatically download, update, and apply the combind Dshield, Spamhaus ip blacklists on your Mikrotik Router:

First: Log into Winbox.

Open a terminal and add the following firewall rules

ip firewall raw add chain=prerouting dst-address-list="sbl dshield" action=drop comment="sbl dshield"
ip firewall raw add chain=prerouting dst-address-list="sbl spamhaus" action=drop comment="sbl spamhaus"
ip firewall raw add chain=prerouting dst-address-list="sbl blocklist.de" action=drop comment="sbl blocklist.de"


Now we need to schedule the automated update: Go to system scheduler and create a new task.

Update spamhaus dshield routeros blacklists.

/tool fetch address=www.squidblacklist.org host=www.squidblacklist.org mode=http src-path=/downloads/drop.malicious.rsc


Now we schedule the import task: Go to system scheduler and create a new task.
 /tool fetch address=www.squidblacklist.org host=www.squidblacklist.org mode=http src-path=/downloads/drop.malicious.rsc

/tool fetch address=www.squidblacklist.org host=www.squidblacklist.org mode=http src-path=/downloads/drop.malicious.rsc


Support Our Efforts – Subscribe Today.

Flat rate subscription. Select a membership option & subscribe.



Select Payment Option



  • You will be issued a username and password.
  • You will be granted access to our member area.
  • 3 Year Membership Option now available.
  • Contact us if you would like a pre order invoice.

Disclaimer: All sales are final, we do not issue refunds. Cancel your subscription anytime.


5 Replies to “Mikrotik RouterOS Malicious IP Blacklist – Firewall Import Script – Gratis”

  1. Hi Squidblacklist
    The filer rules is no correct, I belief it must look like this.

    /ip firewall filter add chain=input src-address-list=drop.dshield action=drop log=yes comment=”drop.dshield”
    /ip firewall filter add chain=input src-address-list=drop.spamhaus1 action=drop log=yes comment=”drop.spamhaus1″
    /ip firewall filter add chain=input src-address-list=drop.spamhaus2 action=drop log=yes comment=”drop.spamhaus2″

    Bigfoot

  2. [* Shield plugin marked this comment as “trash”. Reason: Failed GASP Bot Filter Test (comment token failure) *]
    For recent RouterOS version syntax for creating rules is:
    /ip firewall filter add chain=input src-address-list=drop.dshield action=drop log=yes log-prefix=drop.dshield
    /ip firewall filter add chain=input src-address-list=drop.spamhaus1 action=drop log=yes log-prefix=drop.spamhaus1
    /ip firewall filter add chain=input src-address-list=drop.spamhaus2 action=drop log=yes log-prefix=drop.spamhaus2

  3. [* Shield plugin marked this comment as “trash”. Reason: Failed GASP Bot Filter Test (comment token failure) *]
    Hi guys! Thanks so much for this! Just a quick note: The text under the second Schedule is incorrect and should be the same as the text in the photo for the related schedule rather than a copy of the first schedule. Here is the text it should be for your convenience:

    :log warning “Disabling system logging”;
    import drop.malicious.rsc
    /system logging enable 0

Leave a Reply

Your email address will not be published. Required fields are marked *

*